Scheduled for August 22, 2025 at 10:00 PM – 10:13 PM
Affects
Frankfurt
Under maintenance from 10:00 PM to 10:13 PM
Cloud Servers
Under maintenance from 10:00 PM to 10:13 PM
EU Standard Cloud - 1
Under maintenance from 10:00 PM to 10:13 PM
Completed
August 22, 2025 at 10:13 PMCompleted
August 22, 2025 at 10:13 PMOur maintenance has been completed successfully. However, NeoProtect’s maintenance is still ongoing, which may cause short drops or temporary instability. Please be advised and thank you for your understanding.
In progress
August 22, 2025 at 10:00 PMIn progress
August 22, 2025 at 10:00 PMMaintenance is now in progress
Update
August 22, 2025 at 10:00 PMPlanned
August 22, 2025 at 10:00 PMWe are planning for a scheduled maintenance during that time.
Planned
August 22, 2025 at 7:46 PMPlanned
August 22, 2025 at 7:46 PMWe are moving our Maintenance to match NeoProtect maintenance to August 23rd 00:00 CET Time