Scheduled for October 05, 2025 at 9:00 PM – 10:54 PM
Affects
Frankfurt
Under maintenance from 9:00 PM to 10:54 PM
Cloud Servers
Under maintenance from 9:00 PM to 10:54 PM
EU Standard Cloud - 1
Under maintenance from 9:00 PM to 10:54 PM
Update
October 05, 2025 at 10:54 PMCompleted
October 05, 2025 at 10:54 PMWe have taken additional steps to further improve the network performance and stability of our Standard Node. As part of this upgrade process, some of your VPS/VDS instances were restarted. We sincerely apologize for any inconvenience this may have caused, but these measures are necessary to prevent potential issues in the future.
For Windows servers, restarts and maintenance are being carried out gradually, as they require special handling to ensure data integrity and minimal downtime. These steps are part of our ongoing commitment to provide a stable, reliable, and high-performing environment for all of our customers.
Completed
October 05, 2025 at 9:13 PMCompleted
October 05, 2025 at 9:13 PMMaintenance has completed successfully.
In progress
October 05, 2025 at 9:01 PMIn progress
October 05, 2025 at 9:01 PMMaintenance is now in progress.
Planned
October 05, 2025 at 9:00 PMPlanned
October 05, 2025 at 9:00 PMWe are planning for a scheduled maintenance during that time.