NolimitHost - Chicago Network Outage – Under Monitoring – Incident details

Chicago Network Outage – Under Monitoring

Resolved
Degraded performance
Started about 1 month agoLasted 15 minutes

Affected

Chicago

Major outage from 7:18 PM to 7:32 PM

Datacenter - Chicago

Major outage from 7:18 PM to 7:32 PM

Dedicated Servers

Major outage from 7:18 PM to 7:32 PM

Game Servers

Major outage from 7:18 PM to 7:32 PM

US Premium Game - 1

Major outage from 7:18 PM to 7:32 PM

Cloud Servers

Major outage from 7:18 PM to 7:32 PM

Updates
  • Resolved
    Resolved

    We’ve implemented several fixes and have been working in the background to add a secondary DDoS protection provider in our Chicago location.

    This change comes after NeoProtect was dropped by their upstream provider due to the massive, ongoing DDoS attacks currently impacting multiple networks across the United States.

    To ensure long-term stability and protection, we’re now in the process of integrating a new provider on a similar scale, which will strengthen redundancy and improve overall reliability of our network in Chicago.

    We’ll keep monitoring the situation closely.

    Thank you for your patience and continued trust in NolimitHost.

  • Monitoring
    Monitoring

    Hello,

    We are currently monitoring an outage affecting our Chicago location, caused by a multi-terabit DDoS attack targeting our upstream network.

    Our mitigation systems have already kicked in, and our partners are actively working to stabilize the affected routes.

    At this time, some users may experience temporary connectivity drops or higher latency while traffic is being rerouted through alternate paths.

    Please note that all servers remain intact and online this issue only affects network accessibility for certain routes.

    We’re in close contact with our DDoS protection and network providers to ensure full stability is restored as soon as possible.

    Further updates will be shared as soon as we have more information.

    Thank you for your patience and understanding.